Need glibc 2.8 or bigger for fallocate
authorJens Axboe <axboe@kernel.dk>
Mon, 20 Feb 2012 08:21:45 +0000 (09:21 +0100)
committerJens Axboe <axboe@kernel.dk>
Mon, 20 Feb 2012 08:21:45 +0000 (09:21 +0100)
Signed-off-by: Jens Axboe <axboe@kernel.dk>
os/os-linux.h

index 9f547ff..c0953df 100644 (file)
@@ -34,7 +34,6 @@
 #define FIO_HAVE_RAWBIND
 #define FIO_HAVE_BLKTRACE
 #define FIO_HAVE_STRSEP
-#define FIO_HAVE_FALLOCATE
 #define FIO_HAVE_POSIXAIO_FSYNC
 #define FIO_HAVE_PSHARED_MUTEX
 #define FIO_HAVE_CL_SIZE
@@ -50,7 +49,7 @@
  * Can only enable this for newer glibcs, or the header and defines are
  * missing
  */
-#if __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 6
+#if __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 8
 #define FIO_HAVE_LINUX_FALLOCATE
 #endif