[PATCH] Link in known io engines
[fio.git] / engines / fio-engine-splice.c
index 192fbd00bffdf14184a249e481dbfc95ab4e7f07..fa4a6ee1db21ff192d811f1a95dfacc05de35483 100644 (file)
@@ -8,8 +8,11 @@
 #include <errno.h>
 #include <assert.h>
 #include <sys/poll.h>
 #include <errno.h>
 #include <assert.h>
 #include <sys/poll.h>
-#include "fio.h"
-#include "os.h"
+
+#include "../fio.h"
+#include "../os.h"
+
+#ifdef FIO_HAVE_SPLICE
 
 struct spliceio_data {
        struct io_u *last_io_u;
 
 struct spliceio_data {
        struct io_u *last_io_u;
@@ -179,7 +182,7 @@ static int fio_spliceio_init(struct thread_data *td)
        return 0;
 }
 
        return 0;
 }
 
-struct ioengine_ops ioengine = {
+static struct ioengine_ops ioengine = {
        .name           = "splice",
        .version        = FIO_IOOPS_VERSION,
        .init           = fio_spliceio_init,
        .name           = "splice",
        .version        = FIO_IOOPS_VERSION,
        .init           = fio_spliceio_init,
@@ -189,3 +192,34 @@ struct ioengine_ops ioengine = {
        .cleanup        = fio_spliceio_cleanup,
        .flags          = FIO_SYNCIO,
 };
        .cleanup        = fio_spliceio_cleanup,
        .flags          = FIO_SYNCIO,
 };
+
+#else /* FIO_HAVE_SPLICE */
+
+/*
+ * When we have a proper configure system in place, we simply wont build
+ * and install this io engine. For now install a crippled version that
+ * just complains and fails to load.
+ */
+static int fio_spliceio_init(struct thread_data fio_unused *td)
+{
+       fprintf(stderr, "fio: splice not available\n");
+       return 1;
+}
+
+static struct ioengine_ops ioengine = {
+       .name           = "splice",
+       .version        = FIO_IOOPS_VERSION,
+       .init           = fio_spliceio_init,
+};
+
+#endif
+
+static void fio_init fio_spliceio_register(void)
+{
+       register_ioengine(&ioengine);
+}
+
+static void fio_exit fio_spliceio_unregister(void)
+{
+       unregister_ioengine(&ioengine);
+}