Add cross-stripe intel sample verify job
[fio.git] / GFIO-TODO
CommitLineData
008ad07e
JA
1In no particular order:
2
3- Ability to save job files. Probably in an extended gfio format,
4 so we can include options/settings outside of a fio job file.
5
6- End view improvements:
7
8 - Cleanup the layout
9 - Add ability to save the results
10 - Add ability to load end-results as well
11 - Add ability to request graphs of whatever graphing options
12 the fio job included.
13 - Add ability to graph completion latencies, percentiles, etc.
14
15- Add ability to edit job options:
16
17 - We need an options view after sending a job, that allows us to
18 visually see what was parsed, make changes, resubmit.
19
20 - Job options are already converted across the network and
21 are available in gfio_client->o for view/edit. We'll need
22 a FIO_NET_CMD_UPDATE_OPTIONS command to send them back,
23 and backend support for updating an existing set of options.
24
25- Add support for printing end results, graphs, etc.
26
27- Improve the auto-start backend functionality, it's quite buggy.
28
29- Ensure that it works on OSX and Windows. We'll need a bit of porting
30 work there.
31
32- Persistent store of prefences set. This will need a per-OS bit as well,
33 using gfonf on Linux, registry on Windows, ?? on OSX.
34
008ad07e
JA
35- Ensure that local errors go to our log, instead of being displayed on
36 the console.
37
38- Ensure that the whole connect/send/start button logic is sane. Right
39 now it works when you perform the right sequence, but if you connect
40 and disconnect, things can get confused. We'll need to improve how
41 we store and send job files. Right now they are in ge->job_files[]
42 and are always emptied on send. Keep them around?
43
44- Commit rate display is not enabled.
45
46- Group status reporting is not enabled.
47
48- Split gfio.c a bit. Add gfio/ sub directory, and split it into
49 files based on functionality. It's already ~3000 lines long.
50
51- Attempt to ensure that we work with gtk 2.10 and newer. Right
52 now the required version is ~2.18 (not quite known).